Incident with Amazon S3 document storage

Incident Report for Chronograph

Resolved

This incident has been resolved.
Posted Feb 10, 2026 - 19:35 EST

Monitoring

AWS has confirmed significant recovery for DNS resolution errors for Cloudfront distributions. Certain features of our platform rely on this to function properly and as such we have observed an increase in errors while this incident has been ongoing. We will continue to watch for AWS' full resolution of the issue.
Posted Feb 10, 2026 - 17:11 EST

Investigating

AWS has a active issue, we are monitoring
https://health.aws.amazon.com/health/status
Posted Feb 10, 2026 - 17:02 EST
This incident affected: Chronograph (Chronograph Main API).