[Chronograph GP] Proofpoint blocking SendGrid emails, preventing some deliveries
Incident Report for Chronograph
Resolved
Chronograph has worked with Proofpoint to remove the affected IP address from the blocklist, and also implemented additional safeguards including improved reverse DNS to preclude the likelihood of additional blocking in future. As a further safeguard, we will be implementing a separate private IP for email distributions which will be kept “warm” and used as an automated failover.

We have identified the universe of blocked emails and will invoke automatic redelivery to the affected recipients. We do not anticipate any further issues given prior success rates and ongoing successful deliveries throughout the day today.
Posted Mar 22, 2024 - 18:19 EDT
Monitoring
Proofpoint, a blocklist provider for email servers, has inappropriately blocked a broad shared IP address on SendGrid, our transactional email infrastructure provider. This has resulted in a spike in blocked emails on the Chronograph GP platform. We have initiated an IP rotation request and are working with SendGrid to resolve the issue across their wider client base. We will continue to monitor while we await resolution.
Posted Mar 20, 2024 - 11:20 EDT
This incident affected: Email & Notifications (SendGrid API v3).